Slow page loads and other performance degradation
Incident Report for RSA Link
Resolved
The website has remained fully operational and without any negative performance impact over the weekend, and therefore it has been concluded that this incident is fully resolved. Once again we appreciate your patience during the situation and apologize for any inconvenience.
Posted Jan 25, 2021 - 02:07 EST
Monitoring
The vendor has now mitigated the issue and the RSA Link website is once again performing as expected.

This incident will remain open through the weekend as we monitor the situation to ensure that the performance degradation does not return.
Posted Jan 23, 2021 - 01:19 EST
Update
The vendor is still following the mitigation plan and we are awaiting their update. Thank you for your continued patience.
Posted Jan 22, 2021 - 17:59 EST
Update
Progress is being made with the third-party vendors that manage the data sources and a joint action plan has been identified to resolve the situation.
Posted Jan 22, 2021 - 13:36 EST
Update
Performance is steadily improving on RSA Link as many of the global resources and all resources on the home page have now been migrated from the problematic data source. The workaround deployment is still underway and further performance improvement is expected as progress is made.

The root cause of the performance degradation with the original data source is still being actively investigated by the vendor.
Posted Jan 22, 2021 - 12:09 EST
Identified
The issue has been confirmed as being an upstream issue with the asset management system leveraged by both RSA.com and RSA Link, and delayed loading of the files from this data source are resulting in the degraded performance.

The RSA Link team is actively working to move the resources (consisting primarily of CSS, JavaScript and image files) to a separate data source as a workaround. This has already been performed for a significant number of resources and performance has begun improving accordingly. The remaining resources will continue to be migrated while the upstream vendor troubleshoots the root cause.

Performance is expected to steadily improve as more resources are migrated.
Posted Jan 22, 2021 - 11:23 EST
Investigating
The RSA Link website is again currently experiencing performance degradation that is also impacting the RSA.com website, where some RSA Link website elements such as CSS and JavaScript files are hosted. However, the issue may also be relating to the Jive-x platform on which RSA Link is built.

The issue is being actively investigated in order for it to be resolved as quickly as possible. We apologize for any inconvenience.
Posted Jan 22, 2021 - 10:53 EST
This incident affected: RSA Link (Core Website / Platform).