Slow page loads and other performance degradation
Incident Report for RSA Link
Resolved
The issue has been resolved and measures have been taken to ensure that the same root cause will not degrade performance again on RSA Link.
Posted Jan 21, 2021 - 18:05 EST
Investigating
The RSA Link website is currently experiencing performance degradation that is also impacting the RSA.com website, where some RSA Link website elements such as CSS and JavaScript files are hosted. The issue is being actively investigated in order for it to be resolved as quickly as possible. We apologize for any inconvenience.
Posted Jan 21, 2021 - 12:26 EST
This incident affected: RSA Link (Core Website / Platform).