Some users are unable to create and/or update support cases
Incident Report for RSA Link
Resolved
This incident from yesterday involving the inability to open or manage cases has been resolved and most if not all of those who initially reported the issue have confirmed that functionality has once again returned to normal.

Thanks again for your patience during this unfortunate situation.
Posted Feb 26, 2021 - 11:48 EST
Monitoring
A fix has been implemented to address the issue and we are monitoring to ensure the issue does not return.
Posted Feb 25, 2021 - 16:16 EST
Identified
Some users (including RSA Support employees) are reporting that they are unable to successfully create and/or update support cases,, and are seeing one of several error messages. RSA is aware of the issue and its root cause, and are actively working to restore full case portal functionality as urgently as possible. Thank you for your patience.
Posted Feb 25, 2021 - 11:59 EST
This incident affected: RSA Link (Case Portal).